Home Installation Release notes Documentation Support Downloads Tutorials FutureBasic 5 Links

FutureBasic 5 (32-bit editor)

App

FutureBasic 5, a 32-bit app, requires macOS 10.7 to 10.14 but won't run in macOS 10.15+.

It is a good option for those unable to use the latest FutureBasic.

FutureBasic 5.8.5
Released Build Compatibility Requires
June 10, 2019 1 macOS 10.7 to 10.14 Xcode installation

Installing FutureBasic 5

The link below details FutureBasic 5's installation options.

FutureBasic 5 installation notes

SDKs

Apple began removing specific key header files in macOS 10.7 which were needed by FutureBasic 5. FixSDK solves the issue by restoring the missing files. Later FB releases don't require those removed headers, so today FixSDK is unnecessary. See this page for more details on the overall issue.

OSX 10.6 SDK

OSX 10.7 SDK (fixed)

FixSDK

The FixSDK app automates the fixing of older SDKs. It can also be used to backup and restore SDKs between Xcode releases.

FixSDK 1.3.1
Released Build Compatibility Requires
October 15, 2019 1 macOS 10.7+ Xcode installation

Examples

A selection of demos that run in FB5.

FB5 Examples [16.7 MB]